---
title: "CVE-2025-71334: Flowise has arbitrary file access due to missing chat flow id validation"
url: https://erroneo.us/security/cve/CVE-2025-71334/
description: "CVE-2025-71334 (flowise (npm)): Flowise before 3.0.6 contains an arbitrary file access vulnerability due to missing validation that the chatflowId and…"
type: vulnerability-record
section: "Security Digest"
date_published: 2026-06-25
date_modified: 2026-11-03
publisher: erroneo.us
author: erroneo.us Security Desk
cve: "CVE-2025-71334"
kev: false
cvss: 9.3
epss: 0.0436
license: All rights reserved. Quote with attribution and a link.
---

# CVE-2025-71334: Flowise has arbitrary file access due to missing chat flow id validation

**Signal:** Critical and remotely reachable. No known exploitation yet, but it is network-reachable without credentials. (Computed from CISA KEV, EPSS and CVSS; not an editorial verdict.)

## Should you act?

- Not in CISA KEV , but CISA’s SSVC assessment records a public proof-of-concept, so attack code exists.
- EPSS 4.4% , percentile 91: FIRST’s model estimates a 4.4% chance of exploitation activity in the next 30 days, higher than 91% of all scored CVEs (elevated). EPSS is a probability, not a verdict.
- Remotely reachable with no login and no user interaction. If the vulnerable service is exposed to the internet, prioritize it.
- Only applies if your dependency tree includes flowise (npm) >= 2.2.8, < 3.0.6, fixed in 3.0.6 . Check your lockfile, including transitive dependencies.

## What it is

Flowise before 3.0.6 contains an arbitrary file access vulnerability due to missing validation that the chatflowId and chatId parameters are UUIDs or numbers in file handling operations. By supplying a path-traversal value (e.g., '../../../../../tmp') as the chatflow id, an unauthenticated attacker can use the /api/v1/chatflows endpoint (via addBase64FilesToStorage) to write arbitrary files, and the /api/v1/get-upload-file and /api/v1/openai-assistants-file/download endpoints (via streamStorageFile) to read arbitrary files. Arbitrary file write may lead to remote code execution.

## Affected packages

- npm `flowise` >= 2.2.8, < 3.0.6 → fixed: 3.0.6

## Affected products (CVE record)

- Flowise Flowise: < 3.0.6

## Severity

- VulnCheck CVSS 4.0: 9.3 `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`
- VulnCheck CVSS 3.1: 9.8 `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`
- GitHub CVSS 4.0: 9.3 `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`

## Exploitation

- CISA KEV: not listed (no confirmed in-the-wild exploitation known to CISA).
- CISA SSVC assessment: exploitation poc , automatable yes , technical impact total .
- FIRST EPSS (model of 2026-11-05): 4.36% probability of exploitation activity in the next 30 days; percentile 91.

## Sources

- [GitHub Security Advisory (GHSA-q67q-549q-p849)](https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-q67q-549q-p849)
- [Vendor advisory (github.com)](https://github.com/FlowiseAI/Flowise/commit/8bd3de41533de78e4ef6c980e5704a1f9cb7ae6f)
- [Vendor advisory (github.com)](https://github.com/FlowiseAI/Flowise/commit/c2b830f279e454e8b758da441016b2234f220ac7)
- [GitHub Advisory GHSA-q67q-549q-p849](https://github.com/advisories/GHSA-q67q-549q-p849)
- [CVE.org record CVE-2025-71334](https://www.cve.org/CVERecord?id=CVE-2025-71334)
- [NVD entry CVE-2025-71334](https://nvd.nist.gov/vuln/detail/CVE-2025-71334)
- [VulnCheck Advisory: Flowise - Arbitrary File Access via Missing Chat Flow ID Validation](https://www.vulncheck.com/advisories/flowise-arbitrary-file-access-via-missing-chat-flow-id-validation)

---
Source page: https://erroneo.us/security/cve/CVE-2025-71334/ · Security Digest: https://erroneo.us/security/ · More: https://erroneo.us/llms.txt
