---
title: "CVE-2026-118264: Echo: Rejected WebSocket upgrades can bypass Echo route-level access controls"
url: https://erroneo.us/security/cve/CVE-2026-118264/
description: "CVE-2026-118264 (github.com/labstack/echo/v4 (Go)): Echo is a Go web framework. From 4.0.0 until 4.16.1 and 5.4.1, Echo's Proxy middleware selects a raw…"
type: vulnerability-record
section: "Security Digest"
date_published: 2026-10-28
date_modified: 2026-10-30
publisher: erroneo.us
author: erroneo.us Security Desk
cve: "CVE-2026-118264"
kev: false
cvss: 9.1
epss: 0.0043
license: All rights reserved. Quote with attribution and a link.
---

# CVE-2026-118264: Echo: Rejected WebSocket upgrades can bypass Echo route-level access controls

**Signal:** Critical and remotely reachable. No known exploitation yet, but it is network-reachable without credentials. (Computed from CISA KEV, EPSS and CVSS; not an editorial verdict.)

## Should you act?

- No confirmed exploitation. It is not in CISA’s KEV catalog and CISA’s SSVC assessment records no known exploitation. That can change quickly after a public write-up; re-check if you are affected.
- EPSS 0.4% , percentile 37: FIRST’s model estimates a 0.4% chance of exploitation activity in the next 30 days, higher than 37% of all scored CVEs (low). EPSS is a probability, not a verdict.
- Remotely reachable with no login and no user interaction. If the vulnerable service is exposed to the internet, prioritize it.
- Only applies if your dependency tree includes github.com/labstack/echo/v4 (Go) >= 4.0.0, < 4.16.1, fixed in 4.16.1 ; github.com/labstack/echo/v5 (Go) >= 5.0.0, < 5.4.1, fixed in 5.4.1 . Check your lockfile, including transitive dependencies.

## What it is

Echo is a Go web framework. From 4.0.0 until 4.16.1 and 5.4.1, Echo's Proxy middleware selects a raw tunnel from a client WebSocket upgrade request before verifying that the configured upstream accepted the upgrade. If the upstream rejects the upgrade with an ordinary keep-alive response, later HTTP requests on the connection are sent directly to that upstream without passing through Echo's router or route-specific middleware. This can bypass authentication or authorization enforced only by Echo routes, but requires an accessible proxy route, a cooperating rejected-upgrade response, and a target without independent upstream authorization. This issue is fixed in 4.16.1 and 5.4.1.

## Affected packages

- Go `github.com/labstack/echo/v4` >= 4.0.0, < 4.16.1 → fixed: 4.16.1
- Go `github.com/labstack/echo/v5` >= 5.0.0, < 5.4.1 → fixed: 5.4.1

## Affected products (CVE record)

- labstack echo: >= 4.0.0, < 4.16.1, >= 5.0.0, < 5.4.1

## Severity

- GitHub_M CVSS 4.0: 9.1 `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`
- GitHub CVSS 4.0: 9.1 `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`

## Exploitation

- CISA KEV: not listed (no confirmed in-the-wild exploitation known to CISA).
- CISA SSVC assessment: exploitation none , automatable yes , technical impact total .
- FIRST EPSS (model of 2026-11-05): 0.43% probability of exploitation activity in the next 30 days; percentile 37.

## Sources

- [GitHub Advisory GHSA-cxf3-9h37-7rr8](https://github.com/advisories/GHSA-cxf3-9h37-7rr8)
- [CVE.org record CVE-2026-118264](https://www.cve.org/CVERecord?id=CVE-2026-118264)
- [NVD entry CVE-2026-118264](https://nvd.nist.gov/vuln/detail/CVE-2026-118264)
- [github.com](https://github.com/labstack/echo/security/advisories/GHSA-cxf3-9h37-7rr8)
- [github.com](https://github.com/labstack/echo/commit/1855061e572ae9dab727c811d8382f266bfbaaec)
- [github.com](https://github.com/labstack/echo/commit/3fb0ba7e17645bb65611e2a08875d0a2f65c421f)
- [github.com](https://github.com/labstack/echo/releases/tag/v4.16.1)
- [github.com](https://github.com/labstack/echo/releases/tag/v5.4.1)

---
Source page: https://erroneo.us/security/cve/CVE-2026-118264/ · Security Digest: https://erroneo.us/security/ · More: https://erroneo.us/llms.txt
