Security Digest · Vulnerability record

CVE-2026-55276: Apache Tomcat has an Always-Incorrect Control Flow Implementation vulnerability

Always-Incorrect Control Flow Implementation vulnerability in Apache Tomcat meant that special roles and empty authorisation constraints were not included when the effective web.xml was logged.

CVSS 9.1 Critical EPSS 0.6% · p49

Should you act?

Critical and remotely reachable

No known exploitation yet, but it is network-reachable without credentials. This signal is computed from CISA KEV, EPSS and CVSS data; it is not an editorial verdict.

  • No confirmed exploitation. It is not in CISA’s KEV catalog and CISA’s SSVC assessment records no known exploitation. That can change quickly after a public write-up; re-check if you are affected.
  • EPSS 0.6%, percentile 49: FIRST’s model estimates a 0.6% chance of exploitation activity in the next 30 days, higher than 49% of all scored CVEs (low). EPSS is a probability, not a verdict.
  • Remotely reachable with no login and no user interaction. If the vulnerable service is exposed to the internet, prioritize it.
  • Only applies if your dependency tree includes org.apache.tomcat.embed:tomcat-embed-core (Maven) >= 11.0.0-M1, < 11.0.23, fixed in 11.0.23; org.apache.tomcat.embed:tomcat-embed-core (Maven) >= 10.1.0-M1, < 10.1.56, fixed in 10.1.56; org.apache.tomcat.embed:tomcat-embed-core (Maven) >= 9.0.0.M1, < 9.0.119, fixed in 9.0.119; org.apache.tomcat.embed:tomcat-embed-core (Maven) >= 8.5.0, <= 8.5.100, no fixed version listed. Check your lockfile, including transitive dependencies.

What it is

Always-Incorrect Control Flow Implementation vulnerability in Apache Tomcat meant that special roles and empty authorisation constraints were not included when the effective web.xml was logged. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119 which fixes the issue.

From the GitHub advisory

Always-Incorrect Control Flow Implementation vulnerability in Apache Tomcat meant that special roles and empty authorisation constraints were not included when the effective web.xml was logged.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100. Other versions that have reached end of support may also be affected.

Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119 which fixes the issue.

Weakness type: CWE-670.

Product: org.apache.tomcat.embed:tomcat-embed-core (Maven) · Assigned by: apache · Published: 2026-06-29

Affected and fixed versions

EcosystemPackageVulnerableFirst fixed
Mavenorg.apache.tomcat.embed:tomcat-embed-core>= 11.0.0-M1, < 11.0.2311.0.23
Mavenorg.apache.tomcat.embed:tomcat-embed-core>= 10.1.0-M1, < 10.1.5610.1.56
Mavenorg.apache.tomcat.embed:tomcat-embed-core>= 9.0.0.M1, < 9.0.1199.0.119
Mavenorg.apache.tomcat.embed:tomcat-embed-core>= 8.5.0, <= 8.5.100none listed
Mavenorg.apache.tomcat:tomcat>= 11.0.0-M1, < 11.0.2311.0.23
Mavenorg.apache.tomcat:tomcat>= 10.1.0-M1, < 10.1.5610.1.56
Mavenorg.apache.tomcat:tomcat>= 9.0.0.M1, < 9.0.1199.0.119
Mavenorg.apache.tomcat:tomcat>= 8.5.0, <= 8.5.100none listed
Mavenorg.apache.tomcat:tomcat-util-scan>= 11.0.0-M1, < 11.0.2311.0.23
Mavenorg.apache.tomcat:tomcat-util-scan>= 10.1.0-M1, < 10.1.5610.1.56
Mavenorg.apache.tomcat:tomcat-util-scan>= 9.0.0.M1, < 9.0.1199.0.119
Mavenorg.apache.tomcat:tomcat-util-scan>= 8.5.0, <= 8.5.100none listed
VendorProductAffected versions (per CVE record)
Apache Software FoundationApache Tomcat11.0.0-M1 <= 11.0.22, 10.1.0-M1 <= 10.1.55, 9.0.0.M1 <= 9.0.118, 8.5.0 <= 8.5.100

Severity scores

Scored byCVSSScoreVector
CISA-ADP3.19.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
GitHub3.19.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
  • Attack vector: network (remotely reachable)
  • Attack complexity: low
  • Privileges required: none (no login)
  • User interaction: none
  • Scope: unchanged

CVSS measures how bad a flaw is if exploited, not how likely exploitation is. Read it next to the exploitation data below.

Exploitation and urgency

  • CISA KEV: not listed (no confirmed in-the-wild exploitation known to CISA).
  • CISA SSVC assessment: exploitation none, automatable yes, technical impact total.
  • FIRST EPSS (model of 2026-11-04): 0.61% probability of exploitation activity in the next 30 days; percentile 49.

Timeline

  • — CVE record published by apache
  • — GitHub-reviewed advisory GHSA-mqg3-r7h5-24x4 published (critical)
  • — CVE record last updated

Sources and references

Original sources first. Version and fix details should always be confirmed against the vendor or project advisory.

Vendor and project advisories, patches

  1. lists.apache.org lists.apache.org

Vulnerability records

  1. GitHub Advisory GHSA-mqg3-r7h5-24x4 github.com
  2. CVE.org record CVE-2026-55276 cve.org
  3. NVD entry CVE-2026-55276 nvd.nist.gov

Other references from the CVE record and advisory

  1. openwall.com openwall.com
  2. github.com github.com
  3. github.com github.com
  4. github.com github.com
  5. tomcat.apache.org tomcat.apache.org
  6. tomcat.apache.org tomcat.apache.org
  7. tomcat.apache.org tomcat.apache.org

Critical Maven advisories · Today’s Security Digest