Security Digest · Vulnerability record
CVE-2026-65637: Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation
Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990.
CVSS 9.8 Critical EPSS 0.8% · p55
Should you act?
Critical and remotely reachable
No known exploitation yet, but it is network-reachable without credentials. This signal is computed from CISA KEV, EPSS and CVSS data; it is not an editorial verdict.
- No confirmed exploitation. It is not in CISA’s KEV catalog and CISA’s SSVC assessment records no known exploitation. That can change quickly after a public write-up; re-check if you are affected.
- EPSS 0.8%, percentile 55: FIRST’s model estimates a 0.8% chance of exploitation activity in the next 30 days, higher than 55% of all scored CVEs (moderate). EPSS is a probability, not a verdict.
- Remotely reachable with no login and no user interaction. If the vulnerable service is exposed to the internet, prioritize it.
- Only applies if your dependency tree includes
org.apache.tomcat:tomcat-coyote(Maven) >= 11.0.20, < 11.0.25, fixed in 11.0.25;org.apache.tomcat:tomcat-coyote(Maven) >= 10.1.53, <= 10.1.57, fixed in 10.1.59;org.apache.tomcat:tomcat-coyote(Maven) >= 9.0.115, < 9.0.121, fixed in 9.0.121;org.apache.tomcat.embed:tomcat-embed-core(Maven) >= 11.0.20, < 11.0.25, fixed in 11.0.25. Check your lockfile, including transitive dependencies.
What it is
Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990. This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.
From the GitHub advisory
Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990.
This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120.
Users are recommended to upgrade to version 11.0.25, 10.1.59 or 9.0.121, which fix the issue.
Weakness type: CWE-20.
Product: org.apache.tomcat:tomcat-coyote (Maven) · Assigned by: apache · Published: 2026-08-25
Affected and fixed versions
| Ecosystem | Package | Vulnerable | First fixed |
|---|---|---|---|
| Maven | org.apache.tomcat:tomcat-coyote | >= 11.0.20, < 11.0.25 | 11.0.25 |
| Maven | org.apache.tomcat:tomcat-coyote | >= 10.1.53, <= 10.1.57 | 10.1.59 |
| Maven | org.apache.tomcat:tomcat-coyote | >= 9.0.115, < 9.0.121 | 9.0.121 |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | >= 11.0.20, < 11.0.25 | 11.0.25 |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | >= 10.1.53, <= 10.1.57 | 10.1.59 |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | >= 9.0.115, < 9.0.121 | 9.0.121 |
| Vendor | Product | Affected versions (per CVE record) |
|---|---|---|
| Apache Software Foundation | Apache Tomcat | 11.0.20 <= 11.0.24, 10.1.53 <= 10.1.57, 9.0.115 <= 9.0.120 |
Severity scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| CISA-ADP | 3.1 | 9.8 Critical | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
| GitHub | 3.1 | 9.8 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
- Attack vector: network (remotely reachable)
- Attack complexity: low
- Privileges required: none (no login)
- User interaction: none
- Scope: unchanged
CVSS measures how bad a flaw is if exploited, not how likely exploitation is. Read it next to the exploitation data below.
Exploitation and urgency
- CISA KEV: not listed (no confirmed in-the-wild exploitation known to CISA).
- CISA SSVC assessment: exploitation none, automatable yes, technical impact total.
- FIRST EPSS (model of 2026-11-04): 0.75% probability of exploitation activity in the next 30 days; percentile 55.
Timeline
- — CVE record published by apache
- — CVE record last updated
- — GitHub-reviewed advisory GHSA-f525-44xv-f2qj published (critical)
Sources and references
Original sources first. Version and fix details should always be confirmed against the vendor or project advisory.
Vendor and project advisories, patches
- lists.apache.org lists.apache.org
Vulnerability records
- GitHub Advisory GHSA-f525-44xv-f2qj github.com
- CVE.org record CVE-2026-65637 cve.org
- NVD entry CVE-2026-65637 nvd.nist.gov
Other references from the CVE record and advisory
- github.com github.com
- github.com github.com
- github.com github.com
- github.com github.com
- github.com github.com
- github.com github.com
- tomcat.apache.org tomcat.apache.org
- tomcat.apache.org tomcat.apache.org
- tomcat.apache.org tomcat.apache.org