---
title: "CVE-2026-65637: Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation"
url: https://erroneo.us/security/cve/CVE-2026-65637/
description: "CVE-2026-65637 (org.apache.tomcat:tomcat-coyote (Maven)): Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990.…"
type: vulnerability-record
section: "Security Digest"
date_published: 2026-08-25
date_modified: 2026-10-27
publisher: erroneo.us
author: erroneo.us Security Desk
cve: "CVE-2026-65637"
kev: false
cvss: 9.8
epss: 0.00751
license: All rights reserved. Quote with attribution and a link.
---

# CVE-2026-65637: Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation

**Signal:** Critical and remotely reachable. No known exploitation yet, but it is network-reachable without credentials. (Computed from CISA KEV, EPSS and CVSS; not an editorial verdict.)

## Should you act?

- No confirmed exploitation. It is not in CISA’s KEV catalog and CISA’s SSVC assessment records no known exploitation. That can change quickly after a public write-up; re-check if you are affected.
- EPSS 0.8% , percentile 55: FIRST’s model estimates a 0.8% chance of exploitation activity in the next 30 days, higher than 55% of all scored CVEs (moderate). EPSS is a probability, not a verdict.
- Remotely reachable with no login and no user interaction. If the vulnerable service is exposed to the internet, prioritize it.
- Only applies if your dependency tree includes org.apache.tomcat:tomcat-coyote (Maven) >= 11.0.20, < 11.0.25, fixed in 11.0.25 ; org.apache.tomcat:tomcat-coyote (Maven) >= 10.1.53, <= 10.1.57, fixed in 10.1.59 ; org.apache.tomcat:tomcat-coyote (Maven) >= 9.0.115, < 9.0.121, fixed in 9.0.121 ; org.apache.tomcat.embed:tomcat-embed-core (Maven) >= 11.0.20, < 11.0.25, fixed in 11.0.25 . Check your lockfile, including transitive dependencies.

## What it is

Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990. This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

## Affected packages

- Maven `org.apache.tomcat:tomcat-coyote` >= 11.0.20, < 11.0.25 → fixed: 11.0.25
- Maven `org.apache.tomcat:tomcat-coyote` >= 10.1.53, <= 10.1.57 → fixed: 10.1.59
- Maven `org.apache.tomcat:tomcat-coyote` >= 9.0.115, < 9.0.121 → fixed: 9.0.121
- Maven `org.apache.tomcat.embed:tomcat-embed-core` >= 11.0.20, < 11.0.25 → fixed: 11.0.25
- Maven `org.apache.tomcat.embed:tomcat-embed-core` >= 10.1.53, <= 10.1.57 → fixed: 10.1.59
- Maven `org.apache.tomcat.embed:tomcat-embed-core` >= 9.0.115, < 9.0.121 → fixed: 9.0.121

## Affected products (CVE record)

- Apache Software Foundation Apache Tomcat: 11.0.20 <= 11.0.24, 10.1.53 <= 10.1.57, 9.0.115 <= 9.0.120

## Severity

- CISA-ADP CVSS 3.1: 9.8 `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`
- GitHub CVSS 3.1: 9.8 `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`

## Exploitation

- CISA KEV: not listed (no confirmed in-the-wild exploitation known to CISA).
- CISA SSVC assessment: exploitation none , automatable yes , technical impact total .
- FIRST EPSS (model of 2026-11-04): 0.75% probability of exploitation activity in the next 30 days; percentile 55.

## Sources

- [lists.apache.org](https://lists.apache.org/thread/djog953z1ohsyt25bdvhfzbmsy22vgcj)
- [GitHub Advisory GHSA-f525-44xv-f2qj](https://github.com/advisories/GHSA-f525-44xv-f2qj)
- [CVE.org record CVE-2026-65637](https://www.cve.org/CVERecord?id=CVE-2026-65637)
- [NVD entry CVE-2026-65637](https://nvd.nist.gov/vuln/detail/CVE-2026-65637)
- [github.com](https://github.com/apache/tomcat/commit/40012414df828a56126f76a7339669c7c919aae7)
- [github.com](https://github.com/apache/tomcat/commit/8639b20f045c88f356b887204f52e897399f0de7)
- [github.com](https://github.com/apache/tomcat/commit/b823e88da077f5fa973e34d72359bded9f621e3c)
- [github.com](https://github.com/apache/tomcat/releases/tag/10.1.58)
- [github.com](https://github.com/apache/tomcat/releases/tag/11.0.25)
- [github.com](https://github.com/apache/tomcat/releases/tag/9.0.121)
- [tomcat.apache.org](https://tomcat.apache.org/security-10.html)
- [tomcat.apache.org](https://tomcat.apache.org/security-11.html)
- [tomcat.apache.org](https://tomcat.apache.org/security-9.html)

---
Source page: https://erroneo.us/security/cve/CVE-2026-65637/ · Security Digest: https://erroneo.us/security/ · More: https://erroneo.us/llms.txt
